Skip to main content
← All vulnerabilities
CVE-2026-93894

In Vinyl Cache before 9.0,2, workspace buffer overflow vulnerability was found in the .upper() and .lower() string type methods of VCL.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.0.2, 9.0.4
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

In Vinyl Cache before 9.0,2, workspace buffer overflow vulnerability was found in the .upper() and .lower() string type methods of VCL. This can be used as a remote denial of service (DoS) vector to make the child process segfault or assert, and then restart. Effectively exploiting this vulnerability requires prior knowledge about the VCL in use and the ability to craft a request that contains a string that is long enough to fill the remaining workspace at the call site while staying under the different request size limits (http_req_size, http_req_hdr_len, etc.).

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Vinyl-Cache Vinyl Cache

    fixed in 9.0.2

  • Varnish-Software Varnish Cache

    From 9.0.0 · fixed in 9.0.4; From 6.3.0 · through 8.0.2

References 1

vinyl-cache.org