Skip to main content
← All vulnerabilities
CVE-2026-92973

ansi2html 1.7.0a0 through 1.9.3 Cross-Site Scripting via OSC 8

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.9.4
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

ansi2html versions 1.7.0a0 through 1.9.3 contain a cross-site scripting vulnerability in OSC 8 hyperlink handling that fails to validate or escape URL targets. Attackers controlling ANSI text input can inject javascript: schemes or terminate href attributes to execute arbitrary scripts in the context of pages displaying converted output.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • pycontribs ansi2html

    From 1.7.0a0 · fixed in 1.9.4

References 4

GitHub · pycontribs/ansi2html

vulncheck.com