Skip to main content
← All vulnerabilities
CVE-2026-88804GHSA-992F-XH8R-JG2F

Unauthenticated update of public UI settings leading to stored cross-site scripting in Rancher

Published
Last modified
Status
published
Known exploitation
Not listed in CISA KEV
Fix
Fixed in 2.15.2, 2.14.6, 2.13.10, 2.12.14, 2.11.18
Public exploit
None on Exploit-DB
CISA SSVC
  • Exploitation: none
  • Automatable: no
  • Technical impact: total
?

Decision points from CISA's Vulnrichment, assessed (SSVC 2.0.3).

SSVC documentation

Summary

An unauthenticated update of public UI settings could be used by remote attackers to execute a stored cross-site scripting attack in the Rancher UI, in SUSE Rancher 2.15 before 2.15.2, 2.14 before 2.14.6, 2.13 before 2.13.10, 2.12 before 2.12.14 and 2.11 before 2.11.18.

Affected versions

  • Rancher

    From 2.15.0 · fixed in 2.15.2; From 2.14.0 · fixed in 2.14.6; From 2.13.0 · fixed in 2.13.10; From 2.12.0 · fixed in 2.12.14; From 2.11.0se · fixed in 2.11.18

References 1

GitHub · rancher/rancher