Skip to main content
← All vulnerabilities
CVE-2026-88771

A remote code execution vulnerability exists due to improper input validation, which can allow an unauthenticated attacker to execute arbitrary commands

Published
Last modified
published
Listed in CISA KEV
Fix
Fixed in 14.1-73.37, 13.1-64.23, 14.1-73.37 FIPS, 13.1.37.279 FIPS and NDcPP
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: active
  • Automatable: yes
  • Technical impact: total

Summary

The vulnerability affects Citrix NetScaler ADC and NetScaler Gateway, which are network appliances used for application delivery and secure remote access. An unauthenticated attacker could exploit improper input validation to run arbitrary commands on affected systems.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

Improper input validation vulnerability in Citrix NetScaler ADC and Citrix NetScaler Gateway. This issue affects ADC: before 14.1-73.37, before 13.1-64.23, before 14.1-73.37 FIPS, and before 13.1.37.279 FIPS and NDcPP; Gateway: before 14.1-73.37 and before 13.1-64.23 leading to an unauthenticated attacker to execute arbitrary commands.

Timeline

  1. CISA SSVC assessment

    Exploitation: active · Automatable: yes · Technical impact: total

  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CVE published
  4. Record last updated
  5. CISA remediation deadline

    Due date for US federal agencies to patch

  6. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Citrix NetScaler ADC

    fixed in 14.1-73.37; fixed in 13.1-64.23; fixed in 14.1-73.37 FIPS; fixed in 13.1.37.279 FIPS and NDcPP

  • Citrix NetScaler Gateway

    fixed in 14.1-73.37; fixed in 13.1-64.23

References 1

support.citrix.com